<!DOCTYPE html>
<html lang="en" ng-app="PnaNewsApp">
<head>
<base href="https://www.pna.gov.ph">
<meta charset="utf-8" prefix="og: http://ogp.me/ns#">
<title>UST roars to oust UP, gains finals vs Ateneo | Philippine News Agency</title>
<meta name="description" content="MANILA -- University of Santo Tomas completely squandered University of the Philippines&#039; twice-to-beat advantage in the UAAP men&#039;s basketball stepladder playoffs and barged its way to the finals with a hard-earned 68-65 win on Wednesday night at the Mall of Asia Arena in Pasay City.The Growling...">
<meta property="og:title" content="UST roars to oust UP, gains finals vs Ateneo">
<meta property="og:description" content="MANILA -- University of Santo Tomas completely squandered University of the Philippines&#039; twice-to-beat advantage in the UAAP men&#039;s basketball stepladder playoffs and barged its way to the finals with a hard-earned 68-65 win on Wednesday night at the Mall of Asia Arena in Pasay City.The Growling...">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.pna.gov.ph/articles/1085951">
<meta property="og:image" content="https://files01.pna.gov.ph/ograph/2019/10/07/0-02-06-8958b19d495efb0bb6c2fdaeb912fe398bfbc1b8395c8c1a7f0eb8908b3a630bbd239462.jpg">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@pnagovph">
<meta property="twitter:title" content="UST roars to oust UP, gains finals vs Ateneo">
<meta property="twitter:description" content="MANILA -- University of Santo Tomas completely squandered University of the Philippines&#039; twice-to-beat advantage in the UAAP men&#039;s basketball stepladder playoffs and barged its way to the finals with a hard-earned 68-65 win on Wednesday night at the Mall of Asia Arena in Pasay City.The Growling...">
<meta property="twitter:image" content="https://files01.pna.gov.ph/ograph/2019/10/07/0-02-06-8958b19d495efb0bb6c2fdaeb912fe398bfbc1b8395c8c1a7f0eb8908b3a630bbd239462.jpg">
<meta property="fb:app_id" content="1207373562715564">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="google-site-verification" content="9IyQPo_KnMkwoUmIBCNdNOyX6SFFFMkJqxDfXNtLrcE">
<link href="https://www.pna.gov.ph/assets/img/favicons/favicon-16x16.png" rel="shortcut icon" type="image/png">
<link href="https://www.pna.gov.ph/assets/img/favicons/favicon-16x16.png" rel="icon" sizes="16x16" type="image/png">
<link href="https://www.pna.gov.ph/assets/img/favicons/favicon-32x32.png" rel="icon" sizes="32x32" type="image/png">
<link href="https://www.pna.gov.ph/assets/img/favicons/favicon-96x96.png" rel="icon" sizes="96x96" type="image/png">
<link href="https://fonts.googleapis.com/css?family=Oswald:400,700|Roboto:100,100i,400,400i,700,700i|Roboto+Condensed:400,400i,700,700i" media="all" rel="stylesheet" type="text/css" integrity="sha256-ZNVmQYxByLufjC7YzdpY/JYS/nYu2lGtTOr7TjIgluY=" crossorigin="anonymous">
<link href="https://www.pna.gov.ph/assets/css/theme.min.css" media="screen" rel="stylesheet" type="text/css">
<link href="https://www.pna.gov.ph/assets/css/extras.min.css" media="screen" rel="stylesheet" type="text/css">
<meta name="twitter:widgets:csp" content="on">
</head>
<body class="module-" ng-cloak id="body" ng-controller="ApplicationController">
<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v14.0&appId=1207373562715564&autoLogAppEvents=1" nonce="15325288+141"></script>
<div id="wrap" class="template-pna">
<nav id="header" class="navbar navbar-default navbar-static-top" role="navigation" ng-controller="NavbarController">
<div class="wrapper wrapper-top">
<div class="container">
<div class="row">
<div class="col-sm-6">
<button type="button" class="btn btn-default navbar-toggle" ng-click="isCollapsedA = !isCollapsedA">
<span class="sr-only">Toggle navigation</span>
<span class="fa fa-bars"></span>
 </button>
<a class="navbar-brand" href="https://www.gov.ph" target="_blank">GOV.PH</a>
<div class="navbar-area collapse navbar-collapse" ng-class="!isCollapsedA && 'in'">
<ul class="nav navbar-nav">
<li>
<a class="nav-header" href="/">
<span class=""></span>
Home </a>
</li>
<li>
<a class="nav-header" href="/about">
<span class=""></span>
About </a>
</li>
<li>
<a class="nav-header" href="/subscription">
<span class=""></span>
Subscription </a>
</li>
<li>
<a class="nav-header" href="/transparency">
<span class=""></span>
Transparency </a>
</li>
<li>
<a class="nav-header" href="/contact">
<span class=""></span>
Contact </a>
</li>
</ul> </div>
</div>
<div class="col-sm-6 text-right">
<div class="widget widget-search">
<div class="widget-body">
<form class="form-inline" method="get" action="/articles/search">
<div class="form-group">
<div class="input-group">
<input class="form-control" type="text" placeholder="Search" name="q">
<span class="input-group-btn"><button class="btn btn-default" type="submit">Go!</button></span>
</div>
</div>
</form>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="wrapper wrapper-main">
<div class="container">
<div class="row">
<div class="col-xs-12 text-center">
<a href="/">
<img class="visible-sm visible-md visible-lg block-center" src="https://files01.pna.gov.ph/logos/pna/logo-01.png" title="Philippine News Agency" alt="Philippine News Agency Logo">
<img class="visible-xs w-300px block-center" src="/assets/img/logo-mobile.png" title="Philippine News Agency" alt="Philippine News Agency Logo">
</a>
</div>
</div>
</div>
</div>
<div class="wrapper wrapper-foot">
<div class="container">
<div class="row">
<div class="col-xs-12 text-center">
<button type="button" class="btn btn-primary btn-block navbar-toggle" ng-click="isCollapsedB = !isCollapsedB">
<span class="sr-only">Toggle navigation</span>
<span class="fa fa-bars"></span>
</button>
<div class="navbar-area collapse navbar-collapse" ng-class="!isCollapsedB && 'in'">
<ul class="nav navbar-nav">
<li>
<a class="nav-header" href="/">
<span class=""></span>
Home </a>
</li>
<li>
<a class="nav-header" href="/categories/national">
<span class=""></span>
National </a>
</li>
<li>
<a class="nav-header" href="/categories/provincial">
<span class=""></span>
Provincial </a>
</li>
<li>
<a class="nav-header" href="/opinion">
<span class=""></span>
Opinion </a>
</li>
<li>
<a class="nav-header" href="/categories/business">
<span class=""></span>
Business </a>
</li>
<li>
<a class="nav-header" href="/categories/features">
<span class=""></span>
Features </a>
</li>
<li>
<a class="nav-header" href="/categories/health-and-lifestyle">
<span class=""></span>
Health </a>
</li>
<li>
<a class="nav-header" href="/categories/foreign">
<span class=""></span>
Foreign </a>
</li>
<li>
<a class="nav-header" href="/categories/sports">
<span class=""></span>
Sports </a>
</li>
<li>
<a class="nav-header" href="/categories/travel-and-tourism">
<span class=""></span>
Travel </a>
</li>
<li>
<a class="nav-header" href="/categories/environment">
<span class=""></span>
Environment </a>
</li>
<li>
<a class="nav-header" href="/categories/science-and-technology">
<span class=""></span>
SciTech </a>
</li>
</ul> </div>
</div>
</div>
</div>
</div>
</nav>
<div id="content">
<div class="container">
<div class="row">
<div class="controller-col col-xs-12">
<div class="article single-article">
<div class="page-header">
<h1>UST roars to oust UP, gains finals vs Ateneo</h1>
<div class="row byline">
<div class="col-sm-6 cell-1">
<p>
<span class="d-block author mb-2">By Ivan Stewart Saldajeno</span>
<span class="date published"><i class="fa fa-fw fa-lg fa-calendar"></i> November 13, 2019, 9:21 pm</span>
</p>
</div>
<div class="col-sm-6 cell-2 text-right">
<div class="share-block">
<p>Share</p>
<ul class="share-list">
<li class="share share-fb">
<div class="fb-share-button" data-href="https://www.pna.gov.ph/articles/1085951" data-layout="button_count" data-size="large" data-mobile-iframe="true"><a class="fb-xfbml-parse-ignore" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pna.gov.ph%2Farticles%2F1085951&amp;src=sdkpreparse">Share</a></div>
</li>
<li class="share share-twitter">
<a class="" data-href="https://www.pna.gov.ph/articles/1085951" href="https://twitter.com/share?url=https://www.pna.gov.ph/articles/1085951" target="_blank"><span>Twitter</span></a>
</li>
<li class="share share-viber">
<a class="" href="viber://forward?text=UST roars to oust UP, gains finals vs Ateneo: https://www.pna.gov.ph/articles/1085951"><span>Twitter</span></a>
</li>
<li class="share share-mail">
<a class="" href="/cdn-cgi/l/email-protection#dfe0acaabdb5babcabe2849eadabb6bcb3ba82ff8a8c8bffadb0beadacffabb0ffb0aaacabff8a8ff3ffb8beb6b1acffb9b6b1beb3acffa9acff9eabbab1bab0f9bdb0bba6e28fb7b6b3afafb6b1baff91baa8acff9eb8bab1bca6faef9bfaef9efaef9bfaef9e8a8c8bffadb0beadacffabb0ffb0aaacabff8a8ff3ffb8beb6b1acffb9b6b1beb3acffa9acff9eabbab1bab0faef9bfaef9eb7ababaface5f0f0a8a8a8f1afb1bef1b8b0a9f1afb7f0beadabb6bcb3baacf0eeefe7eae6eaee"><span>Twitter</span></a>
</li>
</ul>
</div>
<div class="clearfix"></div>
</div>
</div>
</div>
<div class="row">
<div class="col-sm-9">
<div class="page-content">
<img src="https://files01.pna.gov.ph/category-list/2019/10/07/0-02-06-8958b19d495efb0bb6c2fdaeb912fe398bfbc1b8395c8c1a7f0eb8908b3a630bbd239462.jpg" class="media-object thumbnail image-align-right">
<p><strong>MANILA</strong> -- University of Santo Tomas completely squandered University of the Philippines' twice-to-beat advantage in the UAAP men's basketball stepladder playoffs and barged its way to the finals with a hard-earned 68-65 win on Wednesday night at the Mall of Asia Arena in Pasay City.</p><p>The Growling Tigers survived a fourth-quarter rally from the Fighting Maroons and Renzo Subido buried a triple in the dying seconds to preserve the win.</p><p>UST will face undefeated Ateneo de Manila University in the best-of-three championship series.</p><p>The Growling Tigers appeared to have shut down UP in the first quarter, holding its opponent to just six points in the first quarter.</p><p>But the Fighting Maroons slowly crawled back and even led, 65-61, with 1:53 left in the game.</p><p>However, foul trouble hounded Bright Akhuetie, Noah Webb suffered cramps, and a huge 24-second violation proved to be costly for UP as the Growling Tigers scored five straight points including Subido's shot from way out against Akhuetie's outstretched arm that gave them a 66-65 lead with 23.6 seconds left.</p><p>Javi Gomez De Liano had a chance to give UP the lead back, but he muffed an open putback, and Chabi Yo made two crucial free throws with 4.4 seconds remaining for the final tally.</p><p>James Spencer tried to force overtime, but missed the potential equalizer from long range as time expired.</p><p>Chabi Yo finished with 22 points, 16 rebounds, one assist, one block, and one steal for UST, which became the third team to enter the playoffs as the fourth seed to make the finals.</p><p>Subido added 14 points, four rebounds, two assists, and one steal.</p><p>Akhuetie led UP with 16 markers, 17 boards, four dimes, and two steals.</p><p>The Scores:</p><p>UST 68 -- Chabi Yo 22, Subido 14, Nonoy 12, Abando 11, Ando 3, Cansino 2, Concepcion 2, Paraiso 2, Bataller 0, Huang 0.</p><p>UP 65 -- Akhuetie 16, Manzo 12, Rivero 12, Ju. Gomez de Liano 8, Paras 8, Spencer 3, Ja. Gomez de Liano 2, Prado 2, Webb 2, Murrell 0, Tungcab 0.</p><p>Quarters: 18-6, 29-28, 49-44, 68-65. <em><strong>(PNA)</strong></em></p> </div>
</div>
<div class="col-sm-3">
<div class="panel panel-primary panel-related-posts">
<div class="panel-heading"><h4 class="panel-title">Related Stories</h4></div>
<div class="panel-body">
<ul class="list-unstyled">
<li><a href="/articles/1174910">UAAP cheerdance makes comeback</a></li>
<li><a href="/articles/1172617">With 50-point win over UST, Ateneo sets new UAAP record</a></li>
<li><a href="/articles/1172427">UP Fighting Maroons score 8th straight win</a></li>
<li><a href="/articles/1172122">UST clobbers UE to keep Final 4 hopes alive</a></li>
<li><a href="/articles/1171736">Ateneo nears 1st round sweep; NU whips UST</a></li>
<li><a href="/articles/1170061">Ateneo-UP showdown to highlight UAAP opening March 26</a></li>
<li><a href="/articles/1145768">Asian U19 beach volley tourney set</a></li>
<li><a href="/articles/1137596">PH volleyball team tryout bubble set in Subic</a></li>
<li><a href="/articles/1118367">UST endorses Ayo's appeal</a></li>
<li><a href="/articles/1117151">Sorsogon police clears Aldin Ayo of any violation in UST bubble</a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.pna.gov.ph/articles/1085951"
  },
  "headline": "UST roars to oust UP, gains finals vs Ateneo",
  "image": [
    "https://files01.pna.gov.ph/ograph/2019/10/07/0-02-06-8958b19d495efb0bb6c2fdaeb912fe398bfbc1b8395c8c1a7f0eb8908b3a630bbd239462.jpg"
   ],
  "datePublished": "2019-11-13T21:21:00+08:00",
  "dateModified": "2019-11-13T21:21:00+08:00",
  "author": {
    "@type": "Person",
    "name": "Ivan Stewart Saldajeno"
  },
   "publisher": {
    "@type": "Organization",
    "name": "Philippine News Agency",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.pna.gov.ph/assets/img/default-ograph-01.jpg"
    }
  },
  "description": "MANILA -- University of Santo Tomas completely squandered University of the Philippines' twice-to-beat advantage in the UAAP men's basketball stepladder playoffs and barged its way to the finals with a hard-earned 68-65 win on Wednesday night at the Mall of Asia Arena in Pasay City.The Growling..."
}
</script>
<div id="footer-widget-area" class="footer-widget-area">
<div class="container">
<div class="row">
<div class="col-sm-5">
<div class="widget-area widget-area-footer-1">
<div class="widget widget-footer-about">
<div class="widget-body">
<p><img class="pull-left img-coat-footer" src="/assets/img/ph-coat-of-arms.png" alt="Coat of Arms of the Philippines"> The <strong>Philippine News Agency</strong> is a web-based newswire service of the Philippine government under the supervision of the News and Information Bureau (NIB) of the Presidential Communications Office (PCO).</p> </div>
</div>
</div>
</div>
<div class="col-sm-6 col-sm-offset-1">
<div class="widget-area widget-area-footer-2">
<div class="widget widget-government-links">
<div class="widget-heading">
<h3>Government Links</h3>
</div>
<div class="widget-body">
<ul class="links-list links-list-2 links-list-government">
<li>
<a href="http://president.gov.ph" target="_blank">
Office of the President </a>
</li>
<li>
<a href="http://ovp.gov.ph" target="_blank">
Office of the Vice President </a>
</li>
<li>
<a href="https://www.senate.gov.ph" target="_blank">
Senate of the Philippines </a>
</li>
<li>
<a href="http://www.congress.gov.ph" target="_blank">
House of Representatives </a>
</li>
<li>
<a href="http://sc.judiciary.gov.ph" target="_blank">
Supreme Court </a>
</li>
<li>
<a href="https://pcoo.gov.ph" target="_blank">
Presidential Communications Operations Office </a>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="footer" class="footer">
<div class="container">
<div class="row">
<div class="col-sm-6 text-left">
<p>Copyright 2022 Philippine News Agency. <a href="#">Privacy Policy</a> | <a href="/terms">Terms of Use</a></p>
</div>
<div class="col-sm-6 text-right">
<p class="scroll-to-top"><a href="" smooth-scroll target="body" offset="0"><i class="fa fa-angle-up"></i></a></p>
</div>
</div>
</div>
</div>
</div> 
</div>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "Organization",
  "url": "https://www.pna.gov.ph",
  "logo": "https://files01.pna.gov.ph/logos/pna/logo-ograph.png"
}
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-98173798-1" nonce="15325288+141"></script>
<script nonce="15325288+141" data-cfasync="false">
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-98173798-1');</script>
<script type="text/javascript" nonce="15325288+141" data-cfasync="false">
PnaNews = { basePath: '' };
</script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/jquery.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/jquery-easy-ticker.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/jquery-cycle2.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/jquery-cycle2-captions.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/jquery-featherlight.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/jquery-match-height.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/bootstrap-3.3.7.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/angular.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/angular-animate.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/angular-sanitize.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/angular-smoothscroll.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/angular-loading-bar.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/angular-strap.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/angular-strap-tpl.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/angular-ui-bootstrap.min.js"></script>
<script type="text/javascript" src="https://www.pna.gov.ph/assets/js/main.min.js"></script><script>(function(){var js = "window['__CF$cv$params']={r:'728ab819beda8224',m:'zY6dCPq9oTjESZQCdyBYauWaagOUCa7.SwfNLN9rq04-1657470995-0-AbX9SjmdoNTBHYAES+LIgMUwCzVr5MAzofXCtKtCSINn2wLkfmeY7WN5y548zG8oWlG926qhgeEmT91sYDOFHtdyMCSm0zOcq1xP4/v0+j8vndM13b46JvYHydQDdy5/eP4gXphsjj0F7h00jgyWNp8=',s:[0x540c6ef608,0x0b903d0cf2],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>
